JSLint File is missing in Visual Studio 2008

Mar 6, 2009 at 6:18 AM
I just discovered the possibillity of JSLint / VS integration. It seem's to be a really great idea and I immediatelly tried to instal the JSLint.VS addin into my VS2008. There were no complications during the installation however once I re-started VS2008 again, the JSLint File can't be found and even the build verification does not work. The only possibility is to use the "JSLint selected fragment".

Is there anything I overlooked in configuration or installation?

Thank you for any advice.

Joseph
Aug 4, 2009 at 1:16 PM

Hi Joseph,

Did you get this to work? is anyone monitoring this project? it looks cool, is it worth me installing in current state?

Thanks

Matt

Developer
Aug 27, 2009 at 8:52 AM
bentos wrote:

Hi Joseph,

Did you get this to work? is anyone monitoring this project? it looks cool, is it worth me installing in current state?

Thanks

Matt

 I got it to work fine. Can be a bit buggy and needs a restart of vs every once in a while but worth the trouble.

I submitted a patch that adds an 'ignore' list to suppress some of doug's more annoying errors that he gives no option to disable.

prime suspect is the complaint of 'missing space after function'. lol. visual studio formats it that way whether you like it or not.

 

Anyway, answer is yes, it works. I am going to track down the leak and make it work even better.

 

Aug 31, 2009 at 9:12 AM

Great stuff, I will give it a go then, thanks for the reply.

Oct 29, 2009 at 5:02 PM

I'm having the same problem as the OP, VS2008 SP1, only have the ability to run JSLint on code fragments, as the project builds with no errors otherwise.

sky: can you confirm what version of VS you had installed?